解决Ghost升级到3.18.1后无法启动问题

起因

好久没登上服务器,一上班手贱上去运行了一把ghost update,升级到ghost 3.18.1,结果在重启ghost服务时就卡住了,转了老半天没有结果。手工启动ghost报错。放狗搜了一番,说是Nodejs版本太低的原因。上ghost官网查了兼容列表,确实是推荐使用nodejs v12。于是升级nodejs,再升级了ghost-cli,但是ghost服务还是没法成功启动。

解决方法

开始想偷懒,想着大不了强制升级一次。于是运行强制升级命令。

ghost update --force

结果连升级都报错。

运行ghost doctor,诊断结果报unknown error。

没有办法,尝试直接ghost run,发现网站可以运行,但是会报一个错。

WARN Can't connect to the bootstrap socket (localhost 8000) ECONNREFUSED

打开ghost配置文件config.production.json,发现有一节bootstrap-socket的配置内容。备份配置文件,把该节内容整个删除。

重启ghost,服务恢复正常。

0 回复

发表评论

Want to join the discussion?
Feel free to contribute!

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注